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Adding Right-Click Render Options 
(Windows XP only) 
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Copyright and Terms of Use 
Please leave all references to FridgeMonsters intact in the documentation and code 
examples.  
 
1. Except as otherwise provided, the contents of these notes shall not be reproduced, 
republished, uploaded, posted, transmitted or distributed electronically or non-
electronically in any way, without FridgeMonsters prior written permission. 
 
2. Modification of any of the contents or use of the contents for any other purpose 
will be a violation of FridgeMonsters copyright and other intellectual property rights. 
Graphics and images in these notes are protected by copyright and may not be 
reproduced or appropriated in any manner without written permission of 
FridgeMonsters. 
 
3. FridgeMonsters reserves all rights to deny or restrict access to these notes to any 
particular person or persons, or to block access from a particular Internet address to 
the FridgeMonsters.com Web Site, at any time, without ascribing any reasons 
whatsoever. 
 
4. These Terms of Use shall be governed and construed in accordance with laws of 
the Republic of Singapore. 
 
For full details, please view the Terms of Use document at :  
 
http://www.FridgeMonsters.com/administration/terms.asp 
 
5. Please report any errors in this tutorial to errata@FridgeMonsters.com
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Introduction 
When you install MAYA on your computer scene files automatically get a right-click 
option to Render the scene files (.ma and .mb files). This default Render option will 
render the scene according the settings set in the scene itself.  
 

 
 

In this tutorial you will add your own right-click Render option for MAYA .ma files. 
You will then learn how to customise the right-click Render option with different 
render settings. For example you could create a high-res render option and a low-res 
option.. 
 
Creating a Right-Click Render Option 
To start this tutorial, let’s familiarise ourselves with the steps involved in adding your 
own right-click Render command. We’ll call this new command RenderII. The 
outcome won’t be any different from the existing right-click Render command, but 
later in the tutorial we’ll show you how to customise RenderII with your own 
rendering options (different from the Render Settings in the scene). 
 

1. Open a Windows Explorer window. 
 

Tools > Folder Options > File Types 
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2. In the Registered file types window.. 
select MA Maya ASCII File > Click Advanced 
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3. In the Edit File Type window add a new action by clicking New. 
 

 
 

4. In the Action field, type RenderII. 
5. In the Application used to perform action: use the Browse… button to 

locate the MAYA Render Application. 
 
Note : The MAYA Render application is located in..  
 

C:\Program Files\AutoDesk\your_version_of_MAYA\bin\render.exe 
 
A quick way to locate the path, is to right-click on the MAYA Desktop shortcut 
and open the Properties window. Copy the Target path, but remember to change 
maya.exe to render.exe  
 

6. Click OK. 
7. Double click on the new RenderII Action to open the Editing action for 

type window. 
 

Notice that Windows has added a %1 to the end of the Application path. 
The %1 means that the file name will be included in the command to 
render – However the %1 needs to be within quotation marks (“%1“) as 
listed below. 
 

"C:\Program Files\AutoDesk\your_version_of_MAYA\bin\render.exe" "%1" 
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8. Click OK and Close the Folder Options window. 
9. Right-click on the MA Maya ASCII File, and notice there is now a RenderII 

option. This will allow you to render the MAYA file without launching MAYA 
(saving you memory) with the current Render Settings as defined in the 
scene file. Images will be automatically rendered to the images folder in the 
Project folder.  

 
 
Note : At this stage, the RenderII function will render the scene as defined in the 
scenes Render Settings. 
 
To customise this function and add more options to RenderII follow the steps below. 
 

1. Open a Windows Explorer window. 
Tools > Folder Options > File Types 

2. In the Registered file types window.. 
select MA Maya ASCII File > Click Advanced 

3. In the Edit File Type window select RenderII and then click Edit…  
4. In the Action field, change RenderII to Render - Hardware. 
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5. In the Application used to perform action: enter the path to the MAYA 
render.exe as listed below. 

 
"C:\Program Files\AutoDesk\your_version_of_MAYA\bin\render.exe" "%1" 
 

 
Note :  This allows you to render the MAYA scene using the default settings. You can 
add additional flags to customize the Action command.  
 
"….Autodesk\ your_version_of_MAYA \bin\render.exe" -r hw -s 1 -e 20 -of jpg "%1" 
 

 
 

In the example above -x is called a flag, followed by a value or option (eg. -r hw 
or –e 20): 
 

–r hw : sets the rendering option to hardware rendering, which is a lot 
faster than software rendering. 
–s 10 : sets the start frame to 10. 
–e 50 : sets te end frame to 50.  

 
Note :  Flags are not placed within quotation marks. Only the path to the render 
application and the file name (%1) need quotation marks.  
 
Note :  To cancel the render, just close the Command Prompt window at any time 
during the rendering. 
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Deleting Right-Click Render Options 
 
To delete the right-click option RenderII follow the steps below. 
 

1. Open a Windows Explorer window. 
Tools > Folder Options > File Types 

2. In the Registered file types window.. 
select MA Maya ASCII File > Click Advanced 

3. In the Edit File Type window select RenderII and then click Remove. 
4. In the Confirm dialogue box, click Yes. 
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Render Options 
As discussed earlier in this tutorial, it your render will be much fast is rendered 
without launching MAYA. This can be accomplished by writing a Right-Click function 
as outlined above. It also be accomplished by launching the Render application 
using a Command Prompt.  
 
The advantage of launching the Render application from the Command Prompt is 
not only the render speed, but also the fact that you can include flags and values 
that will over-write the values defined in your scenes Render Settings.  
 
To list the render application options, launch a Command Prompt window. 
 

Start > Accessories > Command Prompt 
 
In the Command Prompt window type render -? 
 

 
 
 
The render options are listed in categories (Common Options, General purpose flags, 
Anti-aliasing quality, Raytracing quality, Motion Blur etc).  
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One of the most useful commands is render –listRenderers, which lists all the 
renderers available on your system (software, hardware, mental ray, vector etc) . 
See the diagram below. 
 

 
 
 
 
An alternative method to list the render settings is to launch MAYA Help (F1) and in 
the Search field type command line options. 
 
 
Note : To access MAYA Help (F1) you need to be running MAYA. A good tip is to 
bookmark MAYA help in your browser so you can access it directly in future, without 
launching MAYA.  
 
Very Important Note : When you launch the render application in a Command 
Prompt window it will automatically use the settings defined in the scenes Render 
Settings unless you explicitly overwrite them using the render flags.  
 
In other words, if the Render Settings in the scene are defined to render Tiff files at 
640 * 480, the render command will follow these settings unless you include the 
flags for output file (-of), the X resolution (-x) and Y resolution (-y).  
 
To make life easier the table below lists some of the more common render flags and 
some examples.. 
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Rendering Flags and Options 
 

General Purpose Rendering Flags 

-r <string> 
Specify which Renderer to use  

(see Query Strings below to list all available renderers) 
eg. –r hw 

-r mr 
Mental Ray renderer 

Note : The Mental Ray render will error out if the Mental Ray 
plug-in is not installed and enabled. 

-s # (float) Start Frame 

-e # (float) End Frame 

-x # (int) X resolution 

-y # (int) Y resolution 

-percentRes # (float) Render at percentage of –x and –y resolution (above) 

-b # (float) By frame (step value) 

-rfs # (int) Specifies what number to start image sequence at. 

-rfb # (int) Specifies what increment to renumber the image 
sequence at. 

-n 0 Use all available processors for rendering 

-cam <camera name> Render from specific camera 
eg. -cam camera1 

-im <image_name> Image Name (this won't affect the file extension) 

-of <string>  Output Format of images. 
eg. jpg, png, tiff, targa, MAYA IFF, MAYA 16 

-b # (float) By frame (or step) for animation sequence 

-pad # (int) Number of digits in the output file frame number 

-rd <drive>:\<foldername> Render Directory : Overwrites  
eg.  -rd c:\maya\project\images 

-fnc (int) 

File Name Convention. 
<1> name 
<2> name.ext 
<3> name.#.ext 
<4> name.ext.# 
<5> name.# 
<6> name#.ext 
<7> name_#.ext 

-mb  <Boolean> Motion Blur on/off. 
eg. –mb 1 or –mb true 

 

Software Renderer Flags 

-r sw Software renderer 

-eaa (int) 

Enable AntiAlias 
(numbered from bottom to top of list) 

<0> Highest Quality 
<1> High Quality 
<2> Medium Quality 
<3> Low Quality 

 

Hardware Renderer Flags 

-r hw  Hardware renderer 

-ehl (Boolean) Enable high quality lighting  
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-tsc (Boolean) Transparent shadow maps  

-ctr # (int) Colour texture Resolution  

-btr # (int) bump texture Resolution  

 

Query Strings 

render -? Lists all render flags 

render -listRenderers Lists all renderers available on your system 

render -help -r mr For more information on using batch rendering with 
Mental Ray 

render -help -r sw For more information on using batch rendering with 
Software Render 

 
 
Examples 
 

render –r sw –s 1 –e 200 –im new_image –of jpg –cam persp  
C:\users\fmonsters\desktop\proj01\scenes\scene02.ma 

 
The example above uses the Software Renderer to render 200 frames (frame 1 to 
frame 200) from scene02.ma. The output files are jpeg, which will be named 
new_image. The file naming convention and anti-aliasing are not defined; therefore 
the render will follow the values defined in the scenes Render Settings. 
 
 

render –r sw –s 3 –e 23 –x 320 –y 240 –eaa 0 –fnc 6 –pad 2 –of png 
–im test  C:\users\fmonsters\desktop\proj01\scenes\scene11.ma 

 
The example above uses the Software Renderer to render 21 frames (frame 3 to 
frame 23) from scene11.ma. The output files are png, which will be named test. The 
output files will be 320 * 240 pixels in resolution. The files will be numbered with 2 
digits (padding). The file naming convention is 6, therefore the files will be named 
name##.ext. The anti-aliasing value is set to 0, which is highest quality. 
 
  

render –r mr –s 101 –e 200 –percentRes 50 –im sht_7 –of jpg –eaa 2 –pad 3 
–fnc 6  C:\users\fmonsters\desktop\proj01\scenes\final05.ma 

 
The example above uses the Mental Ray Renderer to render 100 frames (frame 101 
to frame 200) from final05.ma. The output files are jpeg, which will be named sht_7. 
The output files will be 50% of the resolution defined in the scenes Render Settings. 
The files will be numbered with 3 digits (padding).  The file naming convention is 6, 
therefore the files will be named name###.ext. The anti-aliasing value is set to 2, 
which is medium quality. 
 
 

render –r hw –s 200 –e 249 –x 640 –y 480 –percentRes 25 –ehl true  
C:\users\fmonsters\desktop\proj01\scenes\sc09.ma 

 
The example above uses the Hardware Renderer to render 50 frames (frame 200 to 
frame 249) from sc09.ma. The output files will be 160 * 120 pixels (25% of 640 * 
480). The scene will be rendered with high quality lighting - depending on your 
hardware. The output file (format) and file naming convention are not defined and 
therefore will follow the values defined in the scenes Render Settings. 
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The table below lists some of the more common Command Prompt commands. 
 

 Command Prompt 
up arrow (keyboard) cycle backward through last commands 

down arrow (keyboard) cycle forward through last commands 

* 

wildcard : A replaces characters in a text 
string. 
 
eg. *.jpg : any file ending with .jpg 
      image.* : any image starting with image 
      del *.jpg : deletes all jpgs in the directory 

cd [drive:][path] change directory to [drive:][path] 

cd ..\.. cd .. : a single directory level up 
cd ..\.. : two directory levels up 

cd \ 
change directory to root of current drive. 
 
eg. If you’re on the C drive and type cd \ you’ll 
be taken to root level of the C drive >  C:\ 

dir list current directory 

help 

help : lists all DOS commands 
help command : lists help for a 
particular command  
 
eg. help copy will list 

move [/y] [drive:][path]filename1 filename2 
  

moves files from 1st path to 2nd path. 
[/y] overwrite confirmation prompt (optional).  
 
eg. move /y old*.jpg ..\tmp_folder 
     move ..\tmp_folder\old*jpg 

copy [/y] [drive:][path]filename1 filename2 
copy files from 1st path to 2nd path. 
[/y] overwrite confirmation prompt (optional). 
 
eg. copy ..\tmp_folder\old*.jpg new*.jpg 

del [filename] 

delete one or more files  
 
eg. del image001.jpg  
     del image*.jpg 
     del *.* 

rename [drive:][path]filename1 filename2 

rename filename1 to filename2 
 
eg. rename oldfilename*.jpg 
newfilename*.jpg 

cls  clear the command prompt screen 

mkdir [directory name] create a new directory 

rmdir [/s] [/q] [drive:][path] 

remove a directory 
[/s] removes all subdirectories and file 
including the current directory itself. 
[/q] overwrite confirmation prompt if using 
[/s] option (optional). 

ver  display the version of Windows 

xcopy [/s ] copy directories and subdirectories, 
except empty ones.  

xcopy [/e] copy directories and subdirectories, 
including empty ones. 

 


